单击F5运行程序,这个时候程序报错,出现下面所示的错误:

ArcGIS version not specified. You must call RuntimeManager.Bind before creating any ArcGIS components.

问题解决方案: 在系统的入口添加下面的一行代码

ESRI.ArcGIS.RuntimeManager.Bind();

当然上面这样代码也可以添加到其他的适合的位置,本人感觉放到程序的入口最合适

这里还需要添加一个Reference:ESRI.ArcGIS.Version 完整的参考代码如下所示:

阅读全文

作者的图片

Eric Z

独立开发者

MSTR

China